Windows has always been one of the operating systems which can be installed through a bootable USB Drive, and it is fairly simple to create on from a Windows machine with Windows USB/DVD Tool or any other third-party software.

However, this gets a bit tricky when your daily driver is a macOS device and you don’t have an access to a Windows machine. That being said, your Mac can handle this task fairly easily and create a bootable USB for you in no time.

Also read → How to Create a Windows 11 USB Drive from Windows 10

In this guide, we are going to create a bootable Windows 11 USB drive using Terminal from Mac. So let’s get started.

Pre-requisites

  • Windows 11 ISO File
  • Minimum 8GB USB Flashdrive
  • A macOS Device
  • Target Windows Machine

Create a Windows 11 USB from Mac

First launch the Terminal from the launchpad of your Mac, it might be located in ‘Other’ folder in the Launchpad.

In the Terminal window, issue the following command to get a list of all connected storage drives (internal and external).

diskutil list

From the results, take note of the path of your USB flash drive (which in this case is /dev/disk2, but you could have a different name according to the disks connected to your system). Also, identify the disk partition scheme (which will be present under the FDisk_partition_scheme label in the terminal) as this information would be needed in further steps.

Do this step on your Windows Computer. You would need to know the BIOS Mode of your target machine. To do so, on your Windows computer, press Windows + R, then type msinfo32 in the text box and then click ‘OK’.

After that, locate and check the BIOS Mode field from the opened window. It will be either ‘Legacy’ or ‘UEFI’.

Coming back to Terminal on Mac, once you have the BIOS Mode information of your target machine, you will need to prepare your USB drive by formatting it.

To do so, type the following command according to your target machine BIOS Mode and press Enter to execute it.

Note: Please be sure to replace disk2 in the path in case your USB drive has a different path from the one present here.

If your BIOS Mode is ‘UEFI’, issue the following command:

diskutil eraseDisk MS-DOS "WIN11" GPT /dev/disk2

If your BIOS Mode is ‘Legacy’, issue the following command:

diskutil eraseDisk MS-DOS "WIN11" MBR /dev/disk2

Executing this command may take from few seconds to few minutes, depending on your macOS machine.

For the next step, please keep your ISO file name and its path on your macOS device handy to save yourself from the hassle of trying to find it hastily.

If your file is located in the ‘Downloads’ folder of your macOS device, issue the following command (with the correct file name of the Windows 11 ISO file) in the terminal and press Enter to execute.

hdiutil mount ~/Downloads/<file-name-here>.iso

Since, macOS does not support NTFS, and Windows machine does not recognize an EX-FAT file system as a bootable option, the prepped USB drives are of FAT32 file system only. This creates one hurdle as FAT32 file system does not support files over 4 gigabytes and one of the major file in your Windows 11 ISO file — install.wim exceeds that.

Fortunately, there is a workaround for this, that will let you split the install.wim in two parts to let you copy them to your drive. This process is completely safe as Windows will re-join the split files automatically.

To do that, first type the following in the Terminal to copy all your files from your Windows 11 mounted image, excluding the ‘install.wim’ file.

rsync -vha --exclude=sources/install.wim /Volumes/<Your mounted File Name here>/* /Volumes/WIN11

Note: Please remember to add your mounted file name in the command above at the given path position.

After that, type the following command and press Enter in the Terminal to download ‘Homebrew’.

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

Note: If you have Homebrew already installed on your macOS device. Kindly skip running the following command.

Now, type your account password when prompted, press Enter to continue. You will not be able to see typed letters, it is normal behavior of the Terminal to protect your privacy.

After that, press Enter to install Xcode Command Line Tools on your macOS device. These tools will help to install the tool we need to split the file image.

You will see the ‘Installation Successful’ message in the Terminal once the Homebrew has been installed on your Mac.

Next, type/paste the following command Terminal and press Enter to install a tool called ‘wimlib’, using Homebrew. ‘wimlib’ is the tool we will use to split the ‘install.wim’ file.

brew install wimlib

You will be able to see the path, number of files, and the size of files, once it has completed installing.

Then, use the following command to split the ‘install.wim’ file.

wimlib-imagex split /Volumes/CCCOMA_X64FRE_EN-US_DV9/sources/install.wim /Volumes/WIN11/sources/install.swm 3000

Note: The numerical ‘3000’ at the end of the command denotes the size limit for each new split file. Feel free to change according to your requirements.

Here ‘wimlib’ will create ‘install.wimaa’ with the file size of 3000 megabytes and ‘install.wimab’ will be of 1000 megabytes, since my ‘install.wim’ is off roughly 4 Gigabytes.

This command may take up a few minutes, and some may even see 0% progress till the process is completed. Thus, do not abort it thinking that the process is stuck. Under normal scenarios, you will be able to track the progress.

Once the process has been completed, you will be able to see that in the Terminal.

Now, you can safely eject your USB drive from the finder. Your bootable Windows 11 USB drive is not ready for use.


It might feel a bit overwhelming at first, but it is pretty straightforward once you get the hang of it. Now, you can create a bootable Windows 11 USB drive straight from your Mac!